Author Topic: help pretty please?  (Read 447 times)

ark2010

  • Newbie
  • *
  • Posts: 5
    • View Profile
help pretty please?
« on: May 05, 2009, 05:19:37 PM »
Hi there, I'm new to the forum.

Saw this game and it looks incredible, but... i can't get it to work.
I've surfed through the forums hopeing i'd find something which would help but as of yet i cant so i was wondering if someone could give me a hand.

I d/l the game and then go to the setup bit (I've run the open AL thing)
First of all i go to the mod section and it doesnt seem to register the mod (even though its running through it..) Does this matter? I cant change it either way

I also get a problem with open gl and its extension 'io'. So i tried running the other version and this still comes up with something else. this means i can't get into the game at all.

However, I bought Free Space 2 last night and it works so its something to do with this demo esque thing.
I receive this error as well, dunno if it helps at all.


Error: The required OpenGL extension ' f' is not supported by your current driver version or graphics card.  You can either use the Direct3D rendering engine (non-FRED builds only) or update your video card drivers.


File:d:\c++\freespace\fs2_open 3.6.9\code\graphics\gropenglextension.cpp
Line: 392
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
    gr_opengl_init()    gr_init()    game_init()    game_main()    WinMain()    WinMainCRTStartup()    kernel32.dll 77654911()
    ntdll.dll 777be4b6()
    ntdll.dll 777be489()
------------------------------------------------------------------



My system is Pentium core2 quad
4gb ram
Geforce 9500GT
Windows 32bit


Any help would be greatly appreciated! Really wanna play on this game!

karajorma

  • He is watching YOU
  • Administrator
  • Hero Member
  • *****
  • Posts: 5268
    • View Profile
help pretty please?
« Reply #1 on: May 05, 2009, 05:56:11 PM »
The FS2 version from GoG (which I presume is where you bought it from) is only the retail version. If you installed FS2_Open on top of it (and once this problem is fixed, you definitely should) you're probably see the same error.

The normal cause of this has been that you don't have the latest drivers for your machine. Which ones are you running with?

ark2010

  • Newbie
  • *
  • Posts: 5
    • View Profile
help pretty please?
« Reply #2 on: May 05, 2009, 07:28:09 PM »
Thanks for your fast reply.
How do you mean the problem will happen again? OPnce i have FS2 open installed aswell?

I'm running on 181.22 - Not the lastest, but theyre still pretty new. I cant use the last because im playing empire total war which doesnt work with them.

Thanks again for your reply!

ark2010

  • Newbie
  • *
  • Posts: 5
    • View Profile
help pretty please?
« Reply #3 on: May 06, 2009, 06:16:29 PM »
Does anyone run with a 9500GT? just wondering if its the card or something else...

karajorma

  • He is watching YOU
  • Administrator
  • Hero Member
  • *****
  • Posts: 5268
    • View Profile
help pretty please?
« Reply #4 on: May 06, 2009, 06:43:06 PM »
This could be the extension limit problem now that I think about it. Call up your control panel and see if the extension limit is on. If so, turn it off.

ark2010

  • Newbie
  • *
  • Posts: 5
    • View Profile
help pretty please?
« Reply #5 on: May 06, 2009, 06:52:36 PM »
You absolute legend!!! thanks for that, it is all loading now. thats all it took!

Thanks again!