Game Warden Forums

Freespace => Freespace 2 MODing => Topic started by: Axem on February 21, 2005, 12:55:22 AM

Title: PCS Woes
Post by: Axem on February 21, 2005, 12:55:22 AM
Okay, so I've got a model and I want to put it into FS2. But PCS crashes when trying to convert it. I've left it for up to 20 minutes, and it shows up as not responding in the task manager. I don't even know where to begin looking for the problem. I'm using the latest PCS, 1.3.42, and I think I've got the hierarchy set up right... (See below). The model itself has 6100 polies, no LODs or debris (yet).

I got an earlier version in before, but now it seems like it doesn't want to cooperate.

Any ideas?
Title: PCS Woes
Post by: karajorma on February 21, 2005, 11:57:34 PM
Try converting just the Hull on it's own (with a light attached)

Also I've always stuck a light to the turret base (although I don't know how necessary that is).

(http://homepage.ntlworld.com/karajorma/freespace/FAQ-Images/Modding-Tutorial/Modding-Pic6.jpg)
Title: PCS Woes
Post by: Axem on February 22, 2005, 12:58:36 AM
Just tried it, it still crashes.

What kind of errors make it crash? If it's a modelling thing, it shouldn't be that hard to fix, unless I would have to rework the whole thing.
Title: PCS Woes
Post by: Taristin on February 22, 2005, 01:16:10 AM
Check PCS to make sure that the scaling is correct. I had that error, too, and never realized that the default scaling was set to ERROR!
Title: PCS Woes
Post by: Axem on February 22, 2005, 02:59:52 AM
Nope, it was at 150, and then I tried it again at 1, but it still didn't work.

I've uploaded the ship if anyone wants to try themselves or tell me what I did wrong. There's one with the guns, and one without them. Just ignore the reeeeally crappy texture job, I'm still trying to explore the texturing thing.

Link! (http://www.mts.net/~jmsrmr/gishship.rar)
Title: PCS Woes
Post by: Taristin on February 22, 2005, 04:00:18 AM
Normally, PCS's conversion factor is 20

and it rarely works at anything else...
Title: PCS Woes
Post by: Axem on February 22, 2005, 04:27:18 AM
Ah well, I've had success with it with other factors, but 20 still didn't work.

:sigh:
Title: PCS Woes
Post by: Taristin on February 22, 2005, 04:43:13 AM
It didn't work for me either. I tried your file, and both scenes made PCS hang forever, until I had to close it...
Title: PCS Woes
Post by: karajorma on February 23, 2005, 08:39:21 PM
Fixed it.

I heard this tip ages ago and it's saved many models for me :)

Open the scene in truespace. Create a new plane which doesn't touch your model. Select your model and then boolean subtract the plane. (I had to do it twice but it eventually reduced your model to around 800 polys). I then triangulated it and put it into PCS. Took about 4 seconds to convert :D
Title: PCS Woes
Post by: Axem on February 24, 2005, 12:21:53 AM
What...the...narf...?

Okay, it looks like it works (tons of polies got shaved off), but TS crashes within 5 seconds. But I shall not give up, I'm so close now.

Thanks a ton kara! :biggrin1:
Title: PCS Woes
Post by: Star Dragon on February 25, 2005, 04:12:14 AM
I used Model view it converted in 20 seconds... Will edit this post in a few after I make a Dl link to .pof (I am afraid to edit it when I add shields to a mesh it crashes)...
 
 Opps scratch that, it needs to be oriented first, plus how long is it supposed to be? Right now it's the size of a large Freighter .
Title: PCS Woes
Post by: Axem on February 25, 2005, 04:30:50 AM
It's supposed 700-800m, its supposed to be a cruiser. Not an FS Cruiser mind you. It's for my own mod that will never see the light of day.
Title: PCS Woes
Post by: Star Dragon on February 25, 2005, 05:40:24 AM
damn so it's not gonna go public, I simply LOVE those design elements/style...
     
 EDIT - I got it oriented in TS then reconverted with modelview to get size estimate, got it length wise to 875meters... added gun data to it and fixed a few of your firing points (some were still in center of ship, not matched to proper turrets) I got close but not perfect. I also added 2 engines with 1 glow apiece (to diasble them later). Made a test pof and got it in game took a screen. They blow up nicelyand also they warp out, so the only thing needed to test now is to add a dock path but they did not crash on me at all. OPS! I just re-edited and made the turrets ROTATE!! BTW 2 of the turrets are OFF and rotate off the model I will go back and figure it out later. I laso made more subsystems just to get them started but you need to figure out where you want them.
     
 So go work on a custom texture map now!!!!! BTW I liked your turrets, they are more detailed then they appear far away, I got REAL close to em lol... TOO CLOSE! :P
   
 Edit look for the .rar file I made at the bottom of this post, it contains the game .pof and .pcx textures from your .tga's... If it's ok with you I'd like to mess around some more later with it. Otherwise I will delete it if you want me to? L8tr!
Title: PCS Woes
Post by: Axem on February 25, 2005, 03:21:11 PM
Dude sweet. TS kept crashing, so I couldn't get kara's thing to work.

I'll get to work on giving it a better texture. I'll probably tile the ship but UV map the turrets, since those are in the greatest need of better texturing.

And you're free to mess around with it, just keep me up to date with it. ;)
Title: PCS Woes
Post by: karajorma on February 25, 2005, 04:14:28 PM
What version of TS are you using?

Want me to Boolean it for you? I use TS6.5 though so I'm not 100% certain I'll be able to export it in a format you can use.
Title: PCS Woes
Post by: Axem on February 25, 2005, 05:14:36 PM
I'm using 3.2, I'm tempted to go "upgrade" it since I hear anything above is lightyears ahead.
Title: PCS Woes
Post by: Star Dragon on February 26, 2005, 07:41:54 PM
Hey,  Arms 11, bases 8 adn 18 fly off the model when rotating. Go back and fix the cob. I set all guns to base rotate on Z barrels rotate on X and those are the only bad ones I saw the rest work right...
Title: PCS Woes
Post by: Axem on February 26, 2005, 11:11:46 PM
Okay, try this. Not sure if it'll work or not, I just fiddled with axis related stuff and attempted to give it a slightly better texture job.

Link-erooney (http://www.mts.net/~jmsrmr/gishship2.rar)
Title: PCS Woes
Post by: Star Dragon on February 27, 2005, 08:54:38 AM
Dude I am in way over my head now.. I had a hell of a time getting TS to make your ship right side up (I assumed your protrusion is the bridge in the rear and the gun on that spot is the bottom?). TS has an annoying habit of ignoring what you want to do and it keeps flipping the ship when you just want to rotate one field and turns positive to begative at will (and vice versa). Anyway did you ONLY fix those 3 turrets I listed s having problems? I ask cause when I did the data for the 1st and then later the 2nd turret they both fly off the model now. I stopped doing teh others cause I sensed it was gonna probably happen for the rest. Did you change anything else???
 
 I don't know what's wrong as I am not a modler, all I can say is the first one worked better...
 
 [edit] forgot to mention when you use TS to increaes size to 800meters it causes teh firing points to stayin old positions. I also tried using 3D Eploration to alter size but onlymodel is increased, firing points remained at old position...
Title: PCS Woes
Post by: karajorma on February 27, 2005, 11:27:29 AM
How are you scaling the object SD? I'm using 6.5 but that scales the lights up or down just fine.

Of course you could just change the conversion factor in PCS's options menu.
Title: PCS Woes
Post by: Star Dragon on February 27, 2005, 11:35:02 AM
typing *4.5 in each field... worked fine for the first model, BTW this is TS3.1